Tail lamps staying on

Discussion in 'Z32 Technical' started by youron300, Jan 5, 2019.

  1. youron300

    youron300 New Member

    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Hay guys any one come across there tail lights staying on when you have the ignition on iv tryed changing the little black box in the back but still no good even changed the brake switch .
     
  2. scottyoz1962

    scottyoz1962 Active Member

    Messages:
    2,221
    Likes Received:
    23
    Trophy Points:
    38
    Mate it's actually a little green button switch that sits under the pedal, they get fragile with age and shatter, they coast about 12-15 dollars at any nissan dealer.

    https://www.z1motorsports.com/images/Z32GreenRubberPedalStop.jpg

    https://aus300zx.com/xenforo/index.php?threads/brake-lights-staying-on.322568/
     
  3. youron300

    youron300 New Member

    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Thanks bud I'll give it a go tomorrow hopfully.
     
  4. scottyoz1962

    scottyoz1962 Active Member

    Messages:
    2,221
    Likes Received:
    23
    Trophy Points:
    38
  5. Redhotz

    Redhotz New Member

    Messages:
    25
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    macksville
    I used a small rubber grommet I bought for 30ยข from Clark rubber
     
  6. MagicMike

    MagicMike Mod and Event Coord [QLD] Staff Member

    Messages:
    9,174
    Likes Received:
    100
    Trophy Points:
    63
    I used a 10mm bolt
     
  7. rob260

    rob260 Moderator Staff Member

    Messages:
    14,746
    Likes Received:
    165
    Trophy Points:
    63
    Location:
    Sydney (North)
    A nut and bolt and a washer is all you need.
     

Share This Page