quick question

Discussion in 'Technical' started by beaver, Feb 10, 2018.

  1. beaver

    beaver southern zeds

    Messages:
    5,783
    Likes Received:
    66
    Trophy Points:
    48
    Location:
    yarra valley
    I've disconnected the duel mas to revert back to a single intake( removed the selin duel mas setup) chasing a intermittent misfire.. ie the engine runs fine 99% of the time, but feels like it drops 1-2 cylinders at the most in opportune times, like in traffic.. it will still idle but as soon as I touch the gas the engine wants to die. This seems like mas problem, and I have a code 12 showing on data scan. Disconnecting the harness from the mas setup should not generate a code right? It never has before.. and dose the above description sound like a dying mas?
     
  2. beaver

    beaver southern zeds

    Messages:
    5,783
    Likes Received:
    66
    Trophy Points:
    48
    Location:
    yarra valley
    That should be AFM not mas
     
  3. 260DET

    260DET Active Member

    Messages:
    937
    Likes Received:
    7
    Trophy Points:
    38
    Can't help sorry N/M
     
  4. J3bba

    J3bba He Who Struggles

    Messages:
    171
    Likes Received:
    5
    Trophy Points:
    18
    Something similar happened to me. Idled fine but when I opened the throttle it just wanted to die. Fidled with the CAS sensor connector and then it was fine. Might be similar?
     
  5. Chrispy

    Chrispy Pretentious Upstart

    Messages:
    12,887
    Likes Received:
    368
    Trophy Points:
    83
    Could be your loom. A bit of a break somewhere. Shouldn't get a ECU code changing AFM's unless you do it with the ignition on.
     

Share This Page