Detonation + High idle problem update

Discussion in 'Technical' started by Dan, Nov 21, 2005.

  1. Dan

    Dan New Member

    Well ran through a few things.

    - ECU code showed up naught. Though I expected as much. ECU won't show you if the sensors are not reading correct only that they are within tolerance.

    - Did O2 sensor test. Yep the little light blinked at me 5 times within 10 seconds over a 2 minute interval. It was erractic though still not enough to think about replacing them... yet...

    - Tested the temp sensor it seemed OK. The car was idling high just before I tested it so should be OK.

    - Tested det sensor. No problems. Got continuity. I don't really understand how a det sensor could _cause_ detonation. But worth a look non the less.

    - Checked connectors all clean. I mean like new.

    - Timing OK. Infact I knocked it back a bit. Now running ~ 10deg

    The following things are new on the car:

    - AFM. Brand spanky.
    - TPS. ditto

    So I'm down to a few things I could try:

    - Vac leak. I hate looking for vac leaks on these bloody cars. Maybe I have been barking up the wrong tree with the electronics.

    - Consult/Conzult. This helped be find the AFM problem. As I said above ECU diagnostic dosn't really tell you much. With the Conzult I can see things happen dynamically.

    Anyhow if anyone could shoot through some suggestions by all means do. The hunt continues.:unsure:


  2. lysergic

    lysergic PWRTRIP

    It's possible the two are not related

    Detonation could be fuel pump, fuel filter, fouled injectors, fuel pressure regulator. maybe hooking up a pressure gauge to the fuel line coming from the fuel filter would be a good idea, especially if can be done on dyno.

    High idle could be base idle screw, throttle cable too tight in combination with throttle bodies not closing all the way.
  3. Dan

    Dan New Member

    Thanks for the suggestion

    Actuallty I bought an inline fuel pressure guage about 18 months ago. Will need to fit it check things out. I totally forgot! Filter is not new but not exactly old either. Heres hoping its not the injectors.

    Base idle screw is probably not the issue. Idle fluctuates between high and low. Though it will normally stay at one speed for a number of minutes before changing. Throttle cable is fine. I will need to check the throttle bodies but they appear to be seating. Will pop off the hose to check for gumed up deposits maybe spray some carby cleaner in there. I have cleaned the IAA a few years back.

    The idle problem has been with the car for some time its just getting particularlly worse to the point where it happens every time I drive the car now. I used to get it only once or twice a year which was fixed by connecting then disconnecting the TPS with the engine running.

    Thanks for you assistance.


  4. JEDI-77

    JEDI-77 Jedi Master


    I know how you feel dude... I had detonation probs about a year ago that reared its ugly head after a rebuild. I suggest checking the following things:

    Fuel pressure: I constructed a gauge that I could sit outside of the bonnet and watch the fuel pressure as I drove around. If you want to borrow it, just let me know.

    Fuel pressure regulator: little thing that sits in engine bay near cylinder 6. If its faulty, the fuel pressure may not increase when acclerating.

    Check all your fuel lines

    Replace your fuel filter

    Do a boost / vacuum test

    Check your spark plugs

    Get a spare CAS and MAF from someone and swap them into your car. See if it helps.

    There are more, but I cant remember at the moment. Give me a buzz or drop by at my place one day and will have a chat..:) Hey by the way, I'm about to build a house out near Caroline springs.... dont you live there?

  5. K-zed

    K-zed Secret Squirrel

    A few things to check >>>

    What was yr timing set at & did u test with inductive or direct connect t/light? Inductive is only accurate to a couple of degrees.

    Idle prob could be: a./ faulty Air Regulator ~ see FSM EF & EC section for test proceedure or b./ intake air leak ~ more likely... inspect intake hoses/clamps/vac lines/AAC & PCV hoses.

    I assume you reset the new TPS to correct voltage AND reset ECU by unplugging TPS for a few seconds? If unsure, start car and @ operating temp/idle speed, unplug TPS grey connector briefly, then re-connect.
  6. zed4life (

    zed4life ( Ω vicarious zedder Ω

    Seconded ... what Chicken Legs (K-Zed) said ...............................
  7. black baz

    black baz black 'n blue Bazemy

    forum guidelines state that upstanding members of the forum

    should not be subjected to personal abuse ..( even if his legs are a bit suss ..!!!) do you think his mother would feel ..???;):rolleyes::p:LOL::LOL::LOL:
  8. zed4life (

    zed4life ( Ω vicarious zedder Ω

    She's the one who told me about them... disclaimer

    END OF POINTLESS POSTING IN Z_RELATED... as I was one who complained the other day about this very thing:rolleyes:
  9. Dan

    Dan New Member


    Moved from 15 to 10 degrees. I used inductive however even if it is +/- one or two shouldn't be an issue at an indicated 10 degrees.. Changing the timing had no effect on problems. Currently still at 10.

    TPS was installed correctly. Set the voltage and reset by diconnecting it when car was running waiting a few seconds then plugging it back in.

    Yep could be a vac leak or some sort of vacuum problem. I'll take a look at the air regulator. Thanks for the tip.

    What is it with chickens on this forum. We have had a Masive Chicken, Chicken Bum, and now Chicken legs. Geez! :p


  10. Dan

    Dan New Member

    Hey dude

    Yep I own a Warehouse in Caroloine Springs. You following me around or something.... :rolleyes:

    Next time your in CS give me a call on the mobile. Home most weekends.

    Yep fuel could definatly be an issue and something I will need to look at.

    MAF is new. CAS well it dosn't feel like a CAS sort of problem...but never know I suppose.

    Plugs are at about 1/2 life.
  11. JEDI-77

    JEDI-77 Jedi Master

    just waiting

    for home loan approval (within the next few days). Have already selected the house, now just to have select the land. Looks like it will be in the cairnle area, about 5-10 min up the road from caroline springs heading towards the city.

  12. JEDI-77

    JEDI-77 Jedi Master


    seriously dude, the problems you're having are sounding very much like the ones I had about a year back. I tried everything. Tested and replaced nearly all the engine sensors, or swapped them with known working units. Nothing. Not even Joe could find the problem. My pinging was happening at about 2500rpms under light throttle, hot or cold conditions, but worse on hot days. In the end, the only solution that worked was a UniChip. Told the guy what was happening and his repsonse was "yes, these cars do run high timing at that part of the map". He knocked off a few degree's of timing in that area, and gained me an extra 15rwkw for my NA. Never had a problem since.


Share This Page